设为首页收藏本站

Discuz! Board

 找回密码
 注-册

QQ登录

只需一步,快速开始

搜索
查看: 3844|回复: 3

出色超赢指标xc-15

[复制链接]
发表于 2011-5-31 21:47:22 | 显示全部楼层 |阅读模式
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
离场:=IF(红色持股,JRL,DRAWNULL);
明离场价:=离场,COLORFF99FF,NODRAW;
今离场价:=REF(离场,1)COLOR0000FF,NODRAW;
青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
进:=IF(青色观望,JRH,DRAWNULL);
明进场价:=进,COLOR33AACC,NODRAW;
今进场价:=REF(明进场价,1),COLORFF0000,NODRAW;
黄色低买:VAR19,COLOR33AACC,NODRAW;
洋红离场:VAR1A,COLORMAGENTA,NODRAW;
急跌关注:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORWHITE,NODRAW;
上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),NODRAW,COLOR0000FF;
月:REF(MONTH,BARSCOUNT(CLOSE)-1),NODRAW,COLORFF00FF;
日:REF(DAY,BARSCOUNT(CLOSE)-1),NODRAW,COLOR00FFFF;
STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;
STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;
STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA;
STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;
STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;
STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500;
STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;
STICKLINE(青色观望,CLOSE,O,1.5,0),COLORAAAA00;
STICKLINE(青色观望,CLOSE,O,1,0),COLORCCCC00;
STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00;
CO:=(C-O);
STICKLINE(急跌关注,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急跌关注,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急跌关注,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急跌关注,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急跌关注,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(黄色低买,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(黄色低买,O,O+CO/3,2,0),COLOR338888;
STICKLINE(黄色低买,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(黄色低买,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(黄色低买,O,O+CO/3,0,0),COLOR33EEEE;
STICKLINE(洋红离场,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(洋红离场,O,O+CO/3,2,0),COLOR880088;
STICKLINE(洋红离场,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(洋红离场,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(洋红离场,O,O+CO/3,0.5,0),COLOREE00EE;
压力:MA(REF(HHV(C,30),1),2),POINTDOT,COLOR9DFFFF;
支撑:MA(REF(LLV(C,30),1),2),POINTDOT,COLORABFF46;
PMA:MA(C,5),COLORWHITE,LINETHICK2;
IF(PMA>REF(PMA,1),PMA,DRAWNULL),COLORRED,LINETHICK2;
IF(PMA<REF(PMA,1),PMA,DRAWNULL),COLORGREEN,LINETHICK2;
X:=(3*C+L+O+H)/6;
多空线:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
+13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
+7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
REF(X,20))/210,COLORFF00FF,LINETHICK2;
DD:=多空线<REF(多空线,1);
IF(DD,多空线,DRAWNULL),COLOR00FFFF,LINETHICK2;
A:=(PMA>多空线);
IF(A,多空线,DRAWNULL),COLOR33FF33,POINTDOT,LINETHICK4;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,9,1);
D:=SMA(K,9,1);
J:=3*K-2*D;
X2:=LLV(J,2)=LLV(J,8);
Y:=IF(CROSS(J,REF(J+0.01,1)) AND X2 AND J<20,30,0);
DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X2 AND J<20,LOW*0.98,'★'),COLORYELLOW;
 楼主| 发表于 2011-5-31 21:49:31 | 显示全部楼层

XC-3 KDJ的J值在0以下

KDJ的J值在0以下;CCI指标值在-200附近;股价在BOLL下轨;股价远离5日均10%以上。

TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
BOLL:=MA(CLOSE,20);
UPPER:=BOLL+2*STD(CLOSE,20);
LOWER:=BOLL-2*STD(CLOSE,20);
MA1:=MA(CLOSE,5);
阳线买:CCI<-200  AND J<0 AND CLOSE<LOWER AND CLOSE<MA1/1.1;
 楼主| 发表于 2011-5-31 21:50:33 | 显示全部楼层

XC-5,四线粘合

MA30:=MA(C,30);
MA60:=MA(C,60);
MA90:=MA(C,90);
MA120:=MA(C,120);
MA250:=MA(C,250);
A1:=MAX(MA60,MA90);
A2:=MAX(MA120,A1);
A3:=MAX(MA250,A2);
B1:=MIN(MA60,MA90);
B2:=MIN(MA120,B1);
B3:=MIN(MA250,B2);
MA30>A1 AND REF(MA30,1)<REF(A1,1) AND A1/B3<1.02;
 楼主| 发表于 2011-5-31 22:03:40 | 显示全部楼层

XC-6 四线粘合向上

MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
A1:=MAX(MA5,MA10);
A2:=MAX(A1,MA20);
A3:=MAX(A2,MA30);
B1:=MIN(MA5,MA10);
B2:=MIN(B1,MA20);
B3:=MIN(B2,MA30);
C1:=COUNT(MA5>MA10 AND MA5>REF(MA5,1),1)=1;
C2:=COUNT(MA5>MA10 AND MA5>REF(MA5,1),2)=2;
C3:=COUNT(MA5>MA10 AND MA5>REF(MA5,1),3)=3;
MA10>MA20 AND MA20>MA30 AND (C1 OR C2 OR C3) AND COUNT(A3/B3<1.02,30)>2;
您需要登录后才可以回帖 登录 | 注-册

本版积分规则

小黑屋|手机版|Archiver|数码鹭岛 ( 闽ICP备05008334号 )  

counter

GMT+8, 2018-6-19 21:47 , Processed in 0.148397 second(s), 26 queries .

Powered by Discuz! X3

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表